UADE Plugin for TuneNet on X1000

I am very excited today because there has finally been a release of a UADE (Unix Amiga Delitracker Emulator) and a UADE TuneNet plugin!

It is called uade.lha and is available on OS4Depot.net. I believe UADE port and the TuneNet plugin were ported to X1000 by Fredrik Wikstrom. Thank you very much for this plugin - you made my day!

Up until now I have had to use a very old version of Delitracker on the X1000 to play Amiga custom modules. It needed a lot of configuration to get it working properly and still isn't perfect, as detailed in my previous blog entry here!

UADE is command line based player and I have been hopefully waiting for a TuneNet UADE plugin to make it much nicer to use! And now it is here!

It means that I can finally play most of the Amiga custom formats using TuneNet's UADE plugin now, as shown below!


It has an installer which installs UADE into the folder of your choice, and adds a UADE: assign to that location in your s:user-startup file (I picked Sys:utilities/UADE):


 It then also prompts if you want it to install the TuneNet plugin, which it will do for you as well when you supply the correct TuneNet folder location!

When this is done and you run TuneNet you can go into the settings menu option and select the Plugins tab to verify it is running, as shown below:


I have all the TuneNet plugins installed that are available on OS4Depot.net. It is well worth installing them to get TFMX, SID tune, OGG, FLAC, WMA and other audio format support within TuneNet.

After verifying the plugin for UADE in TuneNet, I then tried out quite a few module formats - a few still don't play, like SMUS and a few other strange ones (Eg. OLD DW format - newer DW files are ok), but now most of the Amiga custom modules can be played in TuneNet using the UADE plugin!



It plays well in the background and I haven't noticed any audio breakup issues that I noticed in the older version of UADE, so very good news!

I have not worked out how to play custom module subsongs manually in TuneNet yet - the next subsong options { and } in the menus don't work and there are no buttons to click for subsongs in the GUI.. It seems the plugin in TuneNet simply plays each subsong in sequence automatically.

So there is still some room for improvement with the UADE plugin but I am very happy that the plugin works and I can now play nearly all my various music formats in TuneNet on the X1000!


Comments

Popular Posts