Installing MAS Player Evolution on A600

Today, as my final bit of upgrade work for the past weekend, I am installing the MAS Player Evolution on the Amiga 600.




If you haven't been following along until now, I suggest checking some of the earlier blog posts first to see all the steps I did during this Amiga 600 upgrade, as there are dependencies now on things installed earlier in the project.

The MAS Player Evolution is a device for playing back MP3 music files using hardware attached to the Parallel port. Playing MP3 files at full quality on a Classic Amiga running less than a 68060 has always been a impossibility due to the limitations of the CPU speed.


Amiga Sound cards with DSP functionality (eg. Delfina) can offload the MP3 decoding task to a separate processor, making it possible to play MP3 files under AmigaOS3 while doing other tasks.

However, most of the sound cards are intended for big box Classic Amigas like A2000/3000/4000.


MAS Player Evolution is different - it was designed with the Amiga 500/600/1200 in mind. It plugs into the Parallel port, and drivers redirect audio to it via the Parallel port. It was built and sold by AmigaKit and is available to purchase from their website www.amigakit.com.


The device itself contains a audio out port, a mixed in RCA cable set (so you can feed the native Amiga audio out via the MAS Player). This provides one output audio port for all the audio.


It also needs the joystick (or mouse) port, and a connector is included for the purpose. A pass through joystick port is included on the MAS Player hardware to allow you to still connect a joystick or mouse to it as normal.


Here is a view of the MAS Player showing the RCA cables, Joystick cable and the device itself:





 Here is a view of the device from the audio out side, showing the audio out port and joystick pass through port:



When connected to the Amiga 600's parallel port, it looks like this - I have the audio port connected to speakers of course and I am not using the joystick bypass at the moment:



Next view shows the joystick port connection from the MAS Player hardware to the Amiga 600 Joystick port. AmigaKit said on their product page that the joystick cable cannot plug in to the Amiga 600, but it seems to work fine for me:



One more view of the back of the Amiga 600 showing the MAS Player hardware plugged in. You can also see the Indivision ECS VGA out and Subway USB cables too.

Clearly I need to make a hole in the rear of the top part of the Amiga 600 to make these cables able to still be there when the case is screwed together again:



I hope to do something a bit more elegant that just make a hole, but we'll see how it pans out later!

AmigaKit references quite a few programs needed to use the MAS Player Evolution on the product page, which I downloaded and transferred via USB flash drive to the Amiga 600. These are the programs when expanded to RAM:



Note that you also need to download the latest version of AmigaAmp for Classic Amiga (2.25) from www.amigaamp.de.

Basically I followed the various readme files on how to install - for mplay just copy the file to c:



For MASMpegDevice there is copying to different places to do:



The read me says you can run a mp3 on boot!



Here is the copy locations for the MASMpegDevice archive:



You can put BootUpMP3 command in your startup-sequence for a boot up Mp3 jingle - but make sure your MAS Player is connected - tried it and then removed it, since I may not always have the MAS Player connected:



The MHI_MASPro archive is the most important - it installs the MHI library used by AmigaAmp to play back MP3 files. run the Install MHI MAS Pro installer:



To configure Amplifier (included with AmigaOS 3.9) to work with the MAS Player hardware, you need to change the MPEG audio player 1.6 configuration settings and the X-Audio/AHI output 1.4 settings to use masmpeg.device:



Here is the MPEG audio player settings screen. You need to change Layer II/III to Hardware (instead of Software). Then specify masmpeg.device for playback, as Unit 0. Buffer and blocksize set as below:



I used the test sample MP3 provided (endsequence.mp3) which played back perfectly via the MAS Player.



However when playing a 192kbps MP3, Amplifier didn't play well at all, stuttering all the time. I read in a forum somewhere (I forget where now) that running blazewcp in the startup-sequence helps the performance. It is available on www.aminet.net. I downloaded it, extracted to RAM: and gave it a try - just copy blazewcp to C: and call it from the startup sequence - the blazewcp.guide covers the installation well:



Although the output was slightly better as promised,  it still stutters playing back MP3 at 192kbps. Since most of my music is that rate, this is an issue for me.

I tried the MAS Player too, but this didn't work at all in my testing - no audio output when playing mp3's through it, and it uses it's own dedicated screen:



So, I downloaded AmigaAmp 2.25 from www.amigaamp.de which uses the MHI library for the MASPlayer rather than the MASMpeg.device driver:



I ran AmigaAmp-Prefs first, with some settings that need to set under System tab - the initial view is as below:



I then made the following changes to it to get it to play MP3 files via the MHI MAS Player library:



I then went to the shell, and went to the folder I copied the AmigaAmp folder to. I copied AmigaAmp to AmigaAmp.old, and copied AmigaAmp.NOFPU to AmigaAmp. This is necessary as the ACA630 accelerator does not have an FPU installed, so AmigaAmp will not run unless you run the noFPU version..

After this I tested an MP3 encoded at 192kbps and success - it worked perfectly! No audio stutter and I can do other tasks in the background while it is playing:



Because of the 8 colour workbench, I turned off the Skin mode on all music players, as the skins render terrible in 8 colours. So the AmigaAmp player above looks a bit simple compared to it on my A4000T, but it still works of course!

I then tried copying some files to a USB flash drive while playing an MP3 and it didn't skip a beat :-)



The Amiga 600 playing AmigaAmp Mp3 files through the MAS Player hardware:





A major limitation to keep in mind though. You can't play back 256kbps MP3 files without stutter, no matter how much buffer and CPU priority you give to AmigaAmp.

Also bear in mind if you own a A500 that MAS Player really does need a 68020 or greater in it. The AmigaKit information suggests keeping to 128kbps or less if you have a 68000. I can't test this, but it is something to keep in mind.

For the playback of 192kbps or less files on my Amiga 600/030, MAS Player Evolution is great, and really allows the Amiga 600 to do something it would not otherwise be able to do!

For the next part of the Amiga 600 upgrade I will be looking at setting up the network support. This always causes problems usually so I expect it will take a bit of time.

Comments

Popular Posts