AmiKit 8.1 Real on Amiga 4000T - Part 1

This weekend I decided to tackle a project I have wanted to do but put off for some time - installing  AmiKit 8.1 Real on my Amiga 4000T!


I also noticed this is my 200th blog post! :-)

After a lot of thought about the current situation with NG Amigas in 2016, I made the decision this past week to give them a rest and go back and enjoy my Classic Amigas for a while.

To that end I put away all of the NG Amiga systems, and setup my Amiga 4000T as the primary machine, for the first time in many years.




I have covered my Amiga 4000T in some detail in this blog here and how to setup Indivision AGA MK2 optimally, so I won't explain too much more about the machine itself except to cover it's specs:

Amiga 4000T with 68060 Cyberstorm Accelerator
90MB RAM
127GB IDE HD connected to Buddha IDE Zorro Card
A4000T PCI bridgeboard
Indivision AGA mkII DVI A4000T compatible (Scandoubled)
Voodoo3 PCI graphics card (RTG)
Deneb USB zorro card
PCI RTL8029 Network card
PCI AC97 compliant sound card with DSP (for MP3 processor independent playback)
High Density Floppy drive (1.76MB)
Two SCSI CDROM drives
1 IDE CDROM drive. (why 3 drives? because I had three bays to fill with no covers :-)

Before I got started on AmiKit 8.1 Real I ran some AGA 060 demos for some relaxation:



Ok, so down to business.

AmiKit 8 is a rather cool optimised for WinUAE, FS-UAE, E-UAE (and Amiga Forever 2016) setup of Workbench 3.1 or AmigaOS 3.9. It is very resource hungry and uses lots of tricks which work great in emulation but not so much on real Amiga systems. It works on Mac, Windows and Linux system.

I even have AmiKit 8 running on the AmigaOne A1222 under Debian Linux 8 from last month:




Amikit 8 can also boot from a USB stick into a Linux base build emulation environment of AmigaOS! Very nice.



But people like me also wanted to run this clever AmiKit system on real Amiga systems.

Hence AmiKit Real project was born - a condensed version of AmiKit 8 that DOES run on any Classic Amiga that has 16MB memory and can run AmigaOS 3.9. It doesn't need a graphics card, and can now even run on ECS machines in 16 colours! Impressive!

The reason I put off doing this AmiKit 8.1 Real build on the A4000T is because I knew it would be a fair amount of work.

I wanted to keep my perfectly setup AmigaOS 3.9 build (circa 2011) on my existing hard disk intact, as it represents many months of work to get it to that point. That setup (for those interested), is 2x2GB partitions, one running AmigaSYS4 on AmigaOS 3.9, and the other the base AmigaOS 3.9 install I had running before. I also have a 122GB Data partition, formatted with SFS.

This A4000T setup was important as I knew I needed to use it to prepare the new hard disk.

Speaking of which, here is the new hard disk for my A4000T - a Micro SD Card!


I bought this very cheap IDE to SD card converter from Ebay to house the SD Card, and a SD to Micro SD converter for the MicroSD card, which is a Toshiba 4GB card.

This setup means I can setup the sd card converter in a free slot on the A4000T so I can easily access the sd card without opening the case.

I plan to keep using the 127GB hard disk as the data partition, so this new hard disk only needs to be large enough for the operating system. 4GB should be plenty.


As you can see the number of SCSI, IDE and floppy cables in the A4000T case makes it hard to make out very much internally!


The 127GB hard disk is connected to the Buddha IDE card, which is the older version with 2 IDE 3.5 inch connectors on it (the newer one has one 3.5 and one 2.5). The CDROM is connected to the other connector, so I temporarily disconnected it so I could start work on prepping the MicroSD for use on the Amiga.

So I power on booting the 127GB hd with the new MicroSD connected also.




My existing build features AFA OS (AROS for AmigaOS), which includes font smoothing, PNG icons, OS4 theme and more! :-)


Anyway, easy to get distracted, sorry!

I fire up HDToolbox and it detected my MicroSD card straight away - excellent!  I was worried about this part and pleasantly surprised it worked immediately.


It's capacity according to AmigaOS 3.9 is 3.6GB - I guess I'll have to go with that.


I install the hard disk RDB:


Next is partitioning - unhelpfully HDToolbox automatically sets it up as 3 partitions!


I set about fixing that - I only want one 3.6GB partition, set as bootable, device name DH0 (my other hard disk is HD0,HD1,HD2 so no conflicts):



After completing the partition setup and accepting the reboot, the hard disk didn't pop up automatically. I needed to go into Mounter to mount it manually:


I could then see it via the Shell info command, but curiously not on the Workbench itself:


I formatted it from the Shell and then it appeared fine. This partition I named AmiKit, as it is needed to be called that for the AmiKit 8.1 Real installation process.

The next step was to copy a working Workbench 3.1 installation to the hard disk partition, which I grabbed from the Workbench310.hdf on my MIST.

I mounted the Workbench310.hdf on FS-UAE on my Mac, and copied the files to a folder on my hard disk (mounted as a hard disk in the emulation). I then copied the files to USB stick and connected to the USB stick to my A4000T via the Deneb.

I then copied the Workbench files to the hard disk partition. Whew!


I could of have installed the Workbench from the install disks, but I figured there had to be a quicker way. Even though my method was fiddly, it was much faster than installing from floppy disk.

Because this is a A4000T with a 68060 in it, I also need to copy the workbench.library (unique to the A4000T), as well as the 68040.library and 68060.library files from the Phase 5 install disk to the hard disk partition or it won't boot from it at all.


I downloaded the AmiKit Real 8.1 install archive, and transferred it to the A4000T via USB stick. I then extracted the zip archive into the new hard disk partition, ready for installation.

I also copied the AmigaOS 3.9 CD files from an iso mounted using DiskImageGUI into a AmigaOS39 drawer, and the Boing Bag 1 and Boing Bag 2 updates into an OSUpdates drawer on the new hard disk.




So, it the new hard disk partition AmiKit looked like this:
 



AmiKit 8.1 Real requires AmigaOS 3.9 installed before it can be installed. AmigaOS 3.9 needs Workbench 3.1 installed for it to be installed...hence the structure above.

With everything ready, I then turned off the Amiga 4000T and disconnected the 127GB hard disk to ensure it wasn't affected by any of the installation work I was about to do.

Ok, time for the power on and boot into the new hard disk using Workbench 3.1. It works!


Next, I need to create an assign for AmigaOS3.9: to point to the AmigaOS39 drawer where the files are located, so I can proceed with the AmigaOS 3.9 installation without needing the CD.


That done, I get on with the installation of AmigaOS 3.9 on the hard disk, upgrading the Workbench 3.1 installation:



All done, reboot time:


Now the hard disk boots up as AmigaOS 3.9 system:


I changed the colours to 256 colours in the Prefs and then did the AmigaOS3.9: assign again, as it is needed to install the Internet software, CDROM driver and Boing Bags 1 and 2 on AmigaOS 3.9.

I then set to work on doing that:





With that done, I then booted up my AmigaOS 3.9 with Boing Bag 2 installation. It is now ready for the next step of installing AmiKit 8.1 Real:


The AmiKit Install program has two prompts and with an Continue on the first one we are underway!


The extraction of the archives over the existing hard disk takes a LONG time, so make a coffee and do something else for a while. Eventually though it does finish:


On reboot though I didn't get what I was hoping to get - instead I got this:


After some mucking around I found I needed to disable the lines in the s:startup-sequence that run the bootscreen - then it booted normally. The tricky bit was I needed to copy an old ed from my Workbench 3.1 disk so I could actually edit the startup-sequence from the new hard disk (the new ed doesn't work in boot no startup-sequence) .

That done, the AmiKit 8.1 Real booted up and it works!


At the moment it is still using the Indivision AGA output as the drivers for the PCI bridgeboard cards are not installed yet, but I am glad to see it working.


At this stage it was midnight so I had run out of time for this weekend.


I did however set the resolution to 1024x768 on the indivision aga using the included black magic cgx drivers in AmiKit. No, I don't know how that works either!


It does look good though:


The next steps will be to get the pci bridgeboard drivers installed for the Voodoo 3 RTG graphics card support, DSP audio card support, USB support and so on...I will cover this in my next blog entry which is Part 2 here!

Comments

  1. Looking good but you made a little extra work for yourself. You CAN install 3.9 to a bare harddrive without having to install 3.1 first. All that you have to do is create the boot disk from the 3.9 CD. I don't remember if the floppy will work with a SCSI CD drive other than the A4000T's built in SCSI. It works with all IDE connected CDs whether motherboard IDE or card based like FastATA or Buddha.

    ReplyDelete
  2. Make sure to update it to AmiKit 8.5! My experience is best when preparing the whole setup in WinUAE and update it there (downloading and updating runs way faster emulated) and then migrate it to an AmigaOS HDD. I have it running on my A3000D 060 Cybervision 64. 24 bit screenmode runs fine except for a few graphics issues in pop up windows :/

    Hopefully we will also get a AmiKit X Real!

    ReplyDelete
  3. Really interesting read as always, I'll have to give this a go on my A4000/060! Must admit, I'm in a similar situation to you, I've not used my OS4 machine much for the last few years, it's only been powered up once in the last 18 months, I'm much more interested in the 68K machines again these days.

    ReplyDelete
  4. Great setup. Based on your experience, how would you judge expectations of its expectations on A600 or A1200 + Vampire

    ReplyDelete
  5. Hello and greetings from here cold Finland.
    Is´s amazing always to read your blogs and total dedication and knowledge to these great vintage macines.
    I desperately need help my own Amiga 4000D project and operating system installation.
    Can I take contact to you directly pm.in any way?

    ReplyDelete

Post a Comment

Popular posts from this blog

Vampire 500 V2 Part 1

Icaros Desktop 2.0 on Acer AspireOne ZG5 Netbook

My A1222 has arrived!