Tuesday, 10 July 2018

Replacement Amiga 500 has arrived

On Monday this week, my replacement Amiga 500 system arrived, purchased untested from Ebay!


I was worried if it would even work given the seller hadn't tested it (no power supply), but the condition was good, no yellowing, no upgrades done and warranty seal intact so I was hopeful. It was a gamble though...

The packaging left a lot to be desired with no padding around the system at all, just the box itself. Very luckily it survived and doesn't appear to have any case damage.


Here is a view of the rear ports:


The build and Serial information on the bottom. Interesting that the Commodore text is in capitals rather than lower case as on my old Amiga 500.


I bought this Amiga 500 to replace an existing Amiga 500 I have since 2016 which no longer works after trying and failing to install the Vampire 500V2 in it at the end of 2016. I covered my initial Amiga 500 setup and upgrade of the older Amiga 500 in this blog here, here and here, and my attempts to fix it with new chips, etc.

I decided life is too short to screw around with the broken Amiga any more, so after a year or so of trying to fix it, I decided to source another one from Ebay, and I managed to get it for $150 which I think is not too bad. I will keep the non-working Amiga for spare parts.

I quickly hooked up a spare Amiga 500 power supply I have, along with my 2017 acquired 15Hz compatible TFT screen and recently acquired AmiVGA adapter (from Ebay) to check it is working.


Success! It works! I get the Workbench 1.3 insert disk screen as below:


As this is a unexpanded Amiga 500, I had to track down some 512k compatible demos to try on it to test the internal floppy drive.

I am pleased to report that the floppy drive and sound output works perfectly too:



I booted up the Workbench 1.3 disk I have to test the mouse function, which appears to be fine.



I plan to add the expansions I originally installed on the non-working Amiga 500 onto this new system. (see the blog entries I linked at the top of this article for more information on these). Given my experiences with the Vampire 500V2 installation on the Amiga 500 breaking it, I am not keen to put it on this one, but part of me does want to get it working so watch this space!

Given this is the middle of the week I decided to quickly install my 512k ram expansion from the old Amiga 500 since it is an easy thing to install and doesn't need me to open up the case yet.


As you can see above, the warranty seal on the Amiga 500 is still intact.

After installing the expansion, I booted it up again and now I have 1MB memory (512k Chip and 512k Fast).


Closer screenshot showing the extra memory.


Given this is the middle of the week I don't have much time to do much else with it upgrade-wise or to check the internals, but hopefully I will find time here and there during the week or next to transfer the upgrades from the non-working Amiga 500 as a starting point.

Not sure if I need the Indivision ECS installed on this Amiga 500 since I can display native 15hz now on my Acer TFT screen, but might add it later since it will de-interlace screens, etc.

Also debating the Gotek internal installation from my old Amiga 500...might keep it external and use the df0 selector upgrade..or maybe not! Maybe an internal gotek and external gotek and go floppy free? :-)

For now though, time to end this blog post as many ECS Amiga demos and games await my attention on the Amiga 500 and writing this is holding me up! More updates on this setup soon :-)


1 comment:

  1. Hi if you change your mind about selling the broken one i would be interested

    ReplyDelete