Saturday, 5 September 2020

A Tale of Two Vampires

Sorry for the delay in blog posts, but today I try to make up for it as I bring you a tale of two Vampires, featuring AmiKit XE. And even a bit of Gotek to boot. This work was carried out throughout the whole of August.

Touching quickly on the Gotek - I already have a Gotek drive installed in my Amiga 500 Checkmate A1500 plus system:


Trouble is the old style digit display. These days the Gotek come with fancy OLED displays to show the name of the floppy disk image and other goodies. I was keen to try it and bought one before COVID-19 started, with the intention of swapping the Gotek in the Checkmate A1500 plus case the next time I did any work in it.

With the release of AmiKit XE for Vampire enabled Classic systems, I had the excuse to swap the Gotek out. Here is the new one:



I then started the task of disassembling the Checkmate A1500 plus case to replace the Gotek drive with the new one:


With the old drive removed, I connected the new Gotek, ready to screw into the drive bay expansion.


I screwed it in and here is the comparison. Note I picked a black 3d printed mounting bay for the new one so it would look better in my black case.


The new one only has mounting holes in two places that I could screw into the expansion bay.


Putting the expansion bay back into the case, I checked the alignment of the new Gotek to the drive bay hole. The news wasn't good:


It is much lower than the old one was! It doesn't fit!

I put them together to show the problem - the new one (on the right) is positioned much lower on the drive mount tray than the old one. 


This means the 3D print drive mount is probably intended for an A600 or A1200, rather than a A500 floppy drive mounting. That is a shame, as it means I couldn't use it. I put the old one back in for now. That was a bust!

Moving quickly on, I was very excited to see the new AmiKit XE version released, especially written for Vampire accelerator owners of Classic Amigas, and even supports the new Vampire V4 Standalone system recently released.




It is clear a lot of work has gone into the release, and as with other recent previous versions of AmiKit, is a commercial product that you need to purchase.

You can buy it in a preloaded CF card, shipped to your door, or buy and download the zip file only and create the CF card yourself using the detailed instructions.




In return for this purchase, you get a fully configured, RTG enabled AmigaOS system with all the bells and whistles, which is able to be installed with AmigaOS 3.1, AmigaOS 3.1.4, AmigaOS 3.9, AmigaOS 4 or Amiga Forever which you supply during the installation as qualifying products.

I have covered AmiKit XE previously in this blog, which is already available under PC emulation (Windows, Linux) or MacOS.

You can also run a cutdown free AmiKit Real 9 for Classic Amigas without a Vampire (minimum 030 accelerator), which I also covered on this blog.

But now at last you can have the full featured AmiKit XE on your Classic Amiga (with Vampire accelerator) with the latest AmiKit XE release.

I have to make a special mention of the awesome real time technical support I received from the author of AmiKit XE (Jan) throughout the installation process and my many troubles, which has turned out to have nothing to do with AmiKit XE. 

I wanted to share more details about the many features of AmiKit XE as part of the blog entry, but fate had other plans, as you will see. I did get to enjoy it fully working for exactly 30 minutes. Hopefully that is enough to tempt more people to try it out :-)


The first Vampire Tale: The V500 V2 AmiKit XE installation

For those who follow my blog regularly, you would know that I have run the Vampire 500 V2 in my Checkmate 1500 Plus cased Amiga 500 system for a while now.

It currently runs CoffinOS r54 from a 32GB CF card, which is <ahem> not very legal unless you legitimately own AmigaOS 3.9 which it is distributed with. Fortunately I do own it legitimately.

That said, I was excited at the prospect of running AmiKit XE for Vampire on this system. I bought the downloadable version and downloaded the zip file, and extracted it on my Amiga 4000D system, using a USB disk to transfer. I then downloaded the various prerequisites from the installation guide:



I originally tried prepping a 32GB CF card (with USB to CF converter) using HDToolbox on my Amiga 4000D. I set it as per the instructions, using PFS3 as the file system.


I then formatted the CF card with PFSformat:


I then downloaded the lzx archive needed to extract the archive to the CF card, and installed it on my Amiga 4000D.



I then started extracting the archive to the CF card partition (connected using USB to CF converter). 


It didn't go well. After a while I got write errors:




I thought I would copy the archive to the CF card first, then extract on the actual CF card. Previously I was extracting from the Amiga 4000D data partition to the CF card.


It is clear that this was not going well either, with constant write failures.


Unfortunately after a while it came up with an even worse write error:


I gave up and connected the CF card directly to the IDE interface on the Amiga 4000D. Then it copied successfully. The moral of the story extracting a large number of files over USB is a game of lottery of whether it works or not.


Anyway, with the extraction of files done to the CF card, I then made sure I had all the files needed for the initial install, as per the installation guide. 

Initially I was trying to use AmigaOS 3.1.4 and had the required files in the AmiKit:Expansion/InstallFiles drawer, as below:


I moved the CF card to my Vampire 500V2 enabled Amiga 500 system and came up with this prompt:


After a reboot it told me I needed to upgrade my Vampire Core version to 2.12. Currently I was running 2.11 Core. 


So I downloaded the required AmigaOS updatable 2.12 core files to try to upgrade the Vampire Core before trying the install again. The upgrade is not included with the AmiKit XE setup. Here is the drawer from the archive I download from the Apollo website, ready to run the installer.


And, it didn't work. Program failed. Great...


I tried a number of times but it gave me the same error every time. I previously upgraded the core from 2.10 to 2.11 without a problem on the Amiga, so I have no idea why this upgrade doesn't work.

So, I decided to ignore it, and just use the existing onboard rom rather than remapping another rom. I copied the AmigaOS 3.9 files from the original CD to the InstallFiles drawer on the CF card to use instead of the 3.1.4 files, which require the remapped 3.1.4 kickstart rom in order to work. OS3.9 doesn't need the remapped rom since it is the same one included in the Vampire itself.

With that done, the pre-flight checks for the installation of the AmkitXE passed without a problem and I could get the install underway:


With the install completed, it rebooted into a wonderful AmiKit XE customised RTG Workbench, and looks very beautiful.


Having used this version under emulation, I can say in my brief play with it that it works just as well.

I ran a game or two from WHDLoad games I copied to the CF Card to try out once the install completed.


However, being me, I wasn't content to leave it like this. The main reason is because although the system worked, the screen display was patchy at 720p output. I need to set a lower screen resolution in order to have a stable display. It is believed the issue was the firmware installed, and that I really did need to install the 2.12 core, which is the minimum required for AmiKit XE.

Since the AmigaOS upgrade method didn't work (as noted above), I purchased a USB Blaster from Bay and after a serious disinfection when it arrived from China, I connected it to the Vampire 500V2.


Closer view of the USB Blaster connected to the JTAG connector on the Vampire V500 V2.


I removed the CF card to prevent issues while flashing the Vampire 500. I needed a Windows PC or Linux machine for the next step, as I needed to download the Intel FPGA Quartus programmers toolkit. I am grateful to the Apollo Vampire Wiki for the instructions on what is needed here, as I have never flashed a FPGA core via a USB blaster before.

To be honest it shouldn't be necessary either, considering there is an AmigaOS patch method which I definitely prefer - it is much simpler. But it didn't work, so...

I had to read the instructions carefully, register to Intel's developer network to download the required free software. I used my Surface Go to run the software, as it was the easiest way to connect a PC to my Vampire in a separate room to my main day to day computers.

I did get it downloaded and installed on the Surface Go.

Getting the USB hardware to recognise under Windows 10 was annoying, and needed some manual intervention. 



As you see, even though I installed the drivers and software, it is not detected:


The not documented trick to get it working is to locate the inf file for the USB Blaster driver, helpfully installed in an obscure folder as part of of the Intel Quartus FPGA programmer tool installation:


Right clicked on the usbblstr.inf and select install. After that, the Device was picked up correctly. Isn't Windows wonderful...


With that done, I could set up the Programmer software to use the USB blaster hardware:



Ok, ready to load the 2.12 core. I chose the slowest x11 core as the Vampire 500V2 is not so fast and that is supposed to be the most compatible core.


Just to remind ourselves, all I wanted to do was get the core updated. I had to waste a bunch of time learning about fpga reprogrammers, setups and more just to do that. This is not something the average Amiga fan would ever do....only crazy Amiga fans like me. And maybe you, since you are reading this! :-)

Anyway, following the instructions from the Apollo Vampire wiki on how to flash the core, I select the program/configure and verify flags for the 2.12 core file I selected.


I then turned on the Amiga 500 (so that Vampire has power) and started the Core update process.


It is working:


All done and flashed successfully. Why couldn't I use the AmigaOS updater....this is much more difficult.


Anyway, now the Vampire V500 v2 is flashed and running the correct 2.12 x11 core.


You can see the new version number here:


But, the problems with the 720p screen resolution persisted and now the system was unstable too, failing to boot to workbench every 3 out of 4 times. 

When I changed the AmiKit XE CF card I created, and booted my CoffinOS CF card, it now has a green workbench screen and it was unstable and crashing now too. So now the position of the system is worse than before.

So yeah, not sure that really worked out well. Oh, and mapping the 3.1, 3.9 or 3.1.4 legitimate kickstart roms via VampireMap still doesn't work.

At this point the developer of AmiKit XE suggested he send me a pre-prepped AmiKit XE CF card to work with, just to rule out something I might have done to stuff things up.

I was grateful to receive it. It soon arrived from Europe, as below:



I backed it up to an image file using my Windows PC, copied the required install files into the dedicated FAT partition on the CF card on my PC also, and then installed it into my Vampire 500V2, ready for installation to begin. The Fat partition make this process much easier than creating the CF card yourself. I recommend getting the CF card version for a very easy setup process:



Here the installation is underway using the Amikit XE branded CF card:




All is proceeding normally:


Install done, reboot time:


I was working live with the developer via Slack to do this installation to make sure it went well. I am so grateful for the assistance and the support was very very welcome. 

I set the CF card speed to "2" the recommended speed.


Screenmode setting time:


I set the screen mode settings to 720p. Turns out you need to set 24bit mode, not 32bit mode.



The system worked, but it was still unstable. The Vampire would lock up quite often on booting or on the Workbench, and the screen resolution was limited to 576p for a stable display without glitching.



I can hear someone probably tell me something like, you need to upgrade the SAGA drivers, or some other inevitable update I missed somewhere. But after all this mucking around and still not having a stable system, I had had enough. The developer and other beta testers suggested my Vampire 500 is faulty. The card cost me $800....great.

I am sorry to Vampire fans out there, but this Vampire 500 V2 hardware is too flaky. It is too unstable and has too many issues to get it working, and to keep it working.

Maybe your experience is different. I really hope so. I read plenty of good stories from people loving their Vampires. But I am burnt now. I am not going to buy another one to replace it.

I decided to rip it out and restore the ACA500 accelerator and 68000 CPU back in the Amiga 500 system with a normal AmigaOS 3.1.4 ROM install running (as it was before I installed the Vampire 500 in it). With that done, the Amiga 500 system rans rock solid reliable and no further lockup or other issues since.

As those who may remember a while ago, I actually have two Vampire accelerators. I also have one for my Amiga 600 too. This leads me nicely onto the second tale.


The second Vampire Tale: The V600 V2 AmiKit XE installation

My Vampire 600 has sat inside the dead Amiga 600 it killed for a long time now. I was so angry it killed the system. This blog post covers the Vampire 600 I did. At that time it briefly worked.

However, after a few days, every time the system booted, the first audio to come out of the system was a high pitched sound and would completely lock the Amiga system solid everytime. If I used AHI to set audio to null device it would boot, but of course, no sound. I wanted to destroy the Vampire with a hammer for destroying a perfectly functional system until I installed it in it.

I bought another Amiga 600 to replace it as I lack the skills to fix such a fault.

Unfortunately the audio output on the replacement Amiga 600 was not perfect, but it least it worked without locking up the system everytime. I left it in a fairly stock state for a long time with no Vampire, running AmigaOS 3.1.4 with A604n, Subway USB and Indivision ECS output. It worked perfectly.

So it was with a lot of trepidation I decided to install the Vampire 600V2 in the Amiga 600 for AmiKit XE, given the failed state of the V500 install.



Here is the Vampire 600 installed in the system. I am using a Amiga converted PC ATX PSU from Amigakit to supply more power as I know all these expansion in the A600 need a beefier PSU than the standard one in order to work properly.


This Vampire has been out of use for a long time, so it is still running the 2.10 gold core. Much older than the 2.11 core in the V500.


But, it worked perfectly out of the box with AmiKit XE. I mean, perfectly! everything works, the remapping works, the 720p output works, no lockups.


I couldn't believe it. Wow, a working Vampire system with no issues! I was so happy.


I fired up OpenTyrian on it and was delighted to be able to enjoy this on my Amiga 600:



I had a look at the Dracula wizard to help with common configuration changes under AmiKit XE:



I was happily listening to mods and feeling good about all things Vampire. I fired up Worthy for some more recent gaming fun.


I then decided I really should update my Vampire core from 2.10 to the 2.11 core being recommended. So I did that:



All went well with that, and I was soon back on the AmiKit XE desktop, running 060 demos on my Amiga 600 and enjoying the full power of the Vampire:


Playback of music videos at 720p is just awesome.


Smooth playback and sound in sync.


I connected my CoffinOS CF card to the A600 as well, and that also worked well.


More 060 demos:


Fixing a problem with my A1200 while enjoying the A600 Vampired.


I then thought I should fix up the IDE CF card on the A600 which was using the ribbon cable that meant it was sitting over the A600 Vampire card, causing the IDE cable, CF card and the Vampire to get very hot. I had a converter that allows the CF card to be positioned over the PCMCIA slot, away from the Vampire. So I opened the case for one last time to do this change.



And disaster.

When I removed the ide ribbon cable, the ide connector pins literally disintegrated from the base of the motherboard!

Clearly it was just too hot. But I can't fix this - I don't have the soldering skills. So my Amiga 600 is now a useless machine. Again.

I was so upset and so angry. 

I finally got a Vampire working well, with AmiKit XE, and then the machine let me down again by me trying to protect it from the very damage that ultimately killed the Ide port.

I angrily scooped up the lot and threw it in the cupboard. And so ends the second tale of Vampires.

To finish this entry, I moved my Amiga 1200 to have more space on the desk, and fixed up the IDE CF card which had decided to corrupt itself for unknown reasons while sitting off and idle for months. 

I have a backup CF image I took of this system, and I can reflash when this happens so it doesn't take long to fix. 


I then enjoyed some 030 AGA demos and promised myself not to buy or play with Vampires again for a long time.

2 comments:

  1. It looks like your V500 might be an early revision where the hdmi output has resistors instead of caps, which could be the reason why the output is flaky at 720p. Have a talk with Majsta and you guys can probably figure out why your card is not on par. :) He's a friendly guy and usually helps out when you ask for help!

    I have a really early revision of the V500, which didn't have the right set of caps. It was really unstable and it wouldn't even boot newer cores. Fortunately for me, I have the soldering skills so I added the appropriate capacitors and it started to be much more stable. :)

    ReplyDelete
  2. The Gotech drive issue you seen looks the same as I had with the floppy for the 1200 version I built, I used a few brass motherboard risers under the drive to raise the height, I suspect you could do the same.

    ReplyDelete