Getting MUI-MPlayer to work on the X1000

I wanted to play video content on my AmigaOne X1000 and found that the built-in DV Player Special Edition in AmigaOS4 is limited in what content it will play, and you have to pay extra for a full version that unlocks most of it's functionality.

Fortunately MPlayer is also available for AmigaOS4, it is free, and will play most video content formats I can throw at it like DIVX, AVI, XVID, MP4, and physical Dvd playback. But this program doesn't work out of the box on the X1000 and setting changes are needed before it works. I will show you what you need to do!

First, You need to download the MUI-MPlayer from OS4Depot.net. Just search for mui-mplayer.

Extract the archive somewhere on your system - I put it in Sys:Utilities/MPlayer. There are two versions of Mplayer included in the extracted archive, Altivec or generic. You can run either version but I recommend the Altivec version on the X1000.

When you first run Mplayer, you get the GUI and you will try to open your favourite video file. However, you will find that it does not play back video content or DVD content at all and just exits on trying to play anything.

To fix this, you need to run Mplayer again, select Settings menu, and then select Preferences. Then in the Preferences window, modify it so it looks like the below screenshot:


Basically we are changing the video display type to cgx_wpa and DVD device name to sb600sata.device:1, which works well with the X1000. Even though the DVD device field is greyed out, it can be modified as per the other fields.

After this you will find the videos will playback as expected, and DVD Playback will also work now.

Hopefully this helps some people out there who hit the same problem with MPlayer!

Comments

  1. awesome info! now I can view all my videos with mui-mplayer :-)

    ReplyDelete
  2. DVPlayer however is highly optimized for OS4/NG Amigas, and registering this software is well worth it, and encourages the author to keep working on it. He already was just about to drop the project...

    ReplyDelete
  3. You can learn to get Mui player to work on x1000 html

    ReplyDelete
  4. Lot of people will benefit from this blog. It is really a problem solving post.

    ReplyDelete

Post a Comment

Popular posts from this blog

Vampire 500 V2 Part 1

Icaros Desktop 2.0 on Acer AspireOne ZG5 Netbook

My A1222 has arrived!